Delayed Settlement
Incident Report for IntegraPay
Resolved
All sorted!
Settlement can be expected within the next few hours
Thanks for bearing with us.
IPHQ
Posted Jul 27, 2020 - 11:34 AEST
Identified
Please note due to technical difficulties with our Australian banking partner, some client may see a delay in settlement, we are working with the bank to resolve this issue.
Currently we expect settlements to be processed today.

Thanks for your patience.

IPHQ
Posted Jul 27, 2020 - 09:56 AEST